Back to Today's Deal

Right Joystick faulty on Controller ( Resolved! )


#1

Hey guys. For ages I’ve only had a Logitech Wingman Extreme controller. No joysticks on that dude.

So now I have um this controller. , literally a few days out of the box.

Mapping the Right Joystick, instead of Up, down, etc, like I get with the Left, it translates as Button 0, 1, etc, which are already mapped to other things. The Left Stick maps and Axis X-, Y+, etc.

So, does the controller have an issue? Do I need drivers? Expert help please.

PS: Need very layman explanations, not one to understand lots of super technical stuff.


#2

first of all, is that in 1 specific game? if yes, test it in other games, some games do not support certain controllers

also, do make sure u install the latest drivers u should be able to download from their site

also, is this supposed to be a good controller? like, is this a known and trusted brand? i dont know, but if not then that might be the issue too

personally i just go with xbox controller for pc always


#3

No idea. My bestie bought it as a surprise gift, so it was a “FREE” brand, lol.

I found the driver on their site, but it’s odd - Windows 10 had no trouble detecting and installing it. Hm.

I’ve tried it with Steam (which is usually mean) and with PCSX2 emulator. I could try it with something from GOG like Stardew Valley?

Thing is, not sure what games I have (if any) that require both Joysticks, so I can really test it out.


#4

Was looking through your games just now. You have this:

Any top-down twin-stick shooter with controller support should be good to check the right stick.

Also any of a myriad of 3D adventure games or FPS games that you move with the left stick and use the right stick to move camera angles should work too.


#5

Herm… You know I’ve never played that, lol. I generally don’t like FPS - first person makes me dizzy and disoriented and my aim is the major suck.

The only 3D adventure, hm. Good idea. Would this count?

Problem with that is the in game config is glitched. It asks you to choose Y/N as the last thing to set, but nothing you press actually works and you get booted back to the start of the controller settings.


#6

Racing game. If you have one.


#7

Glass Wing might work, I have never played it. But looking at the trailer there should be some right stick camera movement there.

Also I suggested State of Anarchy: Master of Mayhem because I know you have the game and I played it before. I did use the KB+Mouse when I played before. So I redownloaded it and tried it with my controller, and that worked fine. Left stick to move, and Right stick to shoot in the direction you want to.


#8

This appears to be Chinese ps2/3 knockoff controller. The company appears to be based out of Hong Kong. Short answer: probably no.

Emulating PS2 games? If so, I’m wondering if you need to install a slightly different driver. Tell the emulator it’s a PS2 controller.

This might work, I don’t remember the key mapping options in the PC version. Switch version works well.


#9

It would. Definitely can change the camera, but can’t get past that configuration glitch. sigh

I’ll try State of Anarchy tomorrow… Nearly 12:30 am and pretty tired. Tried a good few things in Steam. Either the Joystick acts like triangle (or button 1), or the game ignores this controller altogether. Flubber.

Maybe so. Figured if I’m still novice at DMC1, then 5 whenever that lands in my paws will be impossible. I have the 3rd one on Steam, but going backwards not a bad idea. Herm.

Will try Stardew Valley tomorrow too. Guess there are a lot of knockoff controllers out there. Like that MOCUTE one I’ve seen all over Wish.

Thanks for the help so far. More nipping at it tomorrow. Otherwise, bestie has no problems with returning it.


#10

Got Grid 2 for free lately. Don’t think I can run it on this laptop though. >.<


#11

Looking at the specs. Unless your laptop is a toaster, it should work.

I have a specific driver I’ve used for dual shock controllers for PC. That’s a thing for tomorrow though.


#12

It’s an HP Elitebook 2560p that a techie friend of mine upgraded. It has 8 GB RAM and i5 processor, but a lame-o graphics card. I think the Direct X 11 might be the issue.

Did a quick simple test with Joy2Key. Mapped letters to the stick movement. The left stick is flawless. The right key printed ‘h’ (not a letter assigned) and blank spaces, sigh.


#13

Have you tried pressing the analog button and see if that changes the buttons. I had 2 Logitech controllers that were wired together that acted like the controllers in question. After I pressed the analog button I was able to program all buttons separately. Hope this helps :grinning:


#14

Is actually the minimum spec listed. Intel Graphics 3000. FYI that isn’t actually a graphics card, it’s built into the CPU die.

So your laptop is almost a toaster.


#15

Yup, laptop is almost a toaster, hee hee. Pretty good for its age, to be fair to the wee tyke.

Yes, tried that just now. Now the R-left and R-right responds, but not R-up and R-down. T_T. Gonna try to see if the driver from the company site helps any, after breakfast.

Update: Even after installing the driver and reboot, still R-up and down - got nothing. Guess returning it is the last option now.

Thanks to everyone for the great suggestions. Looks like I got a faulty one.


#16

It seems that you haven’t tried to calibrate the controller in windows? Those “unnamed” controllers had plenty of issues to set them up at least that was the case some years ago. I struggled with a few logitech ones. The only way possible was to just install their drivers and then try to emulate xInput with various stuff.

You tried JoyToKey, but I have no idea if it was made better during the years, but it was pretty meh back in the days and taking keyboard inputs and slapping them on the analog sticks never led to good results.

I see you are on windows 10 so it will be an easy search for “Set up USB game controller…” in the windows start menu and when it’s plugged it will be in the menu. I hope there it will say mark it as Controller (XBOX 360 for Windows) with Status “OK”. That’s if the drivers come with xInput emulator build in but I doubt that.
Click Properties and see if everything is working in the TEST tab (it will default to it anyway). The right Analog stick should be X Rotation bar for horizontal movement (increasing it or decreasing it right and left) and Y Rotation bar for UP and down. The triggers should be the Z axis.

Controller%20-%20TEST%20view

If something doesn’t work go to Settings Tab and Calibrate. If you see flickering of some things in the Test view … it’s usually ok because games will compensate with “dead zones”, but calibrating should fix those as well. Follow the instructions there and tell me how it goes.

P.S. I’m using Dual Shock 4 v2.0 for PS4 with DS4Windows.exe which simulates xInput controller and I never had any issues with it. The steam controller settings don’t include fancy features at all so I’m better of seeing buttons marked as xBox controller than sacrificing useful things.


#17

Well that sounds like a lot. Bestie is fixing to return controller today and exchange. It’s odd that only the Right Up and Down refuses to acknowledge now. Will see if I can give this a try before she has to leave, if not, then I have another thing to try in case a replacement gives me the same issue. Cheers. :slight_smile:


#18

The controller might be working perfectly fine … just it’s not acknowledged properly by games and usually that’s always the case. Games supported only xbox controller for more than a decade by default and recently PS4 and steam controllers as well. That’s why I tell you to test it in the windows controller set up to see if every input works. All of those issues exist since controllers are made for PC 20 years ago.

If it works perfectly fine in the Test tab and every button does it’s job… we need just to find a working emulator for it.

On my Logitech RumblePad 2 which was pretty well known to copy PS2, by default the action buttons were always in the wrong order in 95% of the games and the analog stick and the D-pad were always swapped so your issue is probably just on software level.


#19

I do hope so. One game I tried, don’t remember which, likely DMC3, the right and left stick were swapped, so movement was on the right. Now the right stick is just being a nut. Can’t physically get hold of the controller till tomorrow night, so will try your calibration suggestion then.


#20

It comes as USB Vibration Joystick. The left stick works properly and the cursor goes all around the little box with the cross in it. The right stick highlights 1 2 3 4 with analog off, and cursor goes all around its little box with the cross in it, with analog on.

As far as Windows knows, it’s working properly. I didn’t get the same looking window you did.