Shop seems to be broken

When going to the Shop page, the “Thinking Hard” animations show up, and it seems to get no further.

Checking the Developer Tools in Chrome reveals the error:

Uncaught (in promise) TypeError: Cannot read property ‘forEach’ of null
at bundle.bf0e166c.js:12872


I tried to view the Shop using Chrome on my iPhone and it appears to be working properly. But still not on my PC.

That’s strange, do you happen to have any extensions blocking javascript?

mine is working fine, something with your browser?
I am using chrome as well

After further investigation, you are right - debugging through the code, it is GET-ing which is getting

Object {duration: 731, problem: “NETWORK_ERROR”, ok: false, status: null, headers: null…}

as result of it (it seems only as of today) being blocked by the network at my office.

To be fair, I am relatively surprised that the whole site isn’t blocked, but I guess it means I’ll have to start using my phone to view the site at work… :slight_smile:


Damn you corporate overlords!

1 Like