Back to Today's Deal

Notepad file recovered after deletion - looks like gibberish


#21

Not sure what you mean. I didn’t save the recovered file back in the same place they originally were.


#22

Yes, we’re trying to recover the original since the software recovered appears borked.

Give it a whirl for the latest restore point before your cleanup


#23

Last resort, as per always is system restore, yes. Trying out other suggestions made right now. Just opened the Driftland giveaway, so was tidying that up.


#24

Since restoring only sets me back functionally in time, I usually do it fairly early. I can always reinstall things or uninstall them again.


#25

"System Restore uses a feature called System Protection that regularly creates restore points on your computer. You can restore your Windows system files, registry settings, and programs installed on your system.

However, your personal files stored on your computer remain untouched. System Restore cannot help you recover your personal deleted files such as photos, documents, emails, etc. So, you will need to find another way to recover your deleted files."

The above is why I’m not exactly rushing to try it. Notepad doesn’t seem to have autosaves (and therefore backups or other versions) like Word and other such programs, so I don’t see really how much good it could do.


#26

I’m not at my personal computer so I don’t have access to this.

I’m just giving options


#27

Understood and appreciated. Just explaining where I am in the process and why I’m doing what actions etc.


#28

I do like the idea mentioned above of trying notepad++. Notepad is commonly garbage for trying to display anything not in standard coding format.


#29

Unfortunately, it had no effect at all. Good thought though.


#30

Yes, I am using Notepad++ with no success…

TRY the system restore…PLEASE…

I am still playing it with it… But having a NEW laptop…I don’t have the programs I had on my PC>>


#31

Good thinking. Optimally, you would also have turned off the computer immediately when you noticed the file was missing and started the recovery process using an OS running live from a USB-drive. Sorry for the hindsight :frowning:. Manually deleting the file (most likely) only erased the entry/link for said file in the filesystem (I wonder if NTFS has backups for the filesystem entries, or if it’s only for specific folders for system recovery or something) and left the original data sitting where it was on the hard disk. That’s why minimizing writes on the hard disk is important in scenarios like these, because even booting/using the OS and applications creates a lot of data that, in the worst case, ends up where the data you want to recover previously was.

In your scenario it should’ve been quite easy for competent recovery software to restore the file. I haven’t used data recovery software (or Windows for that matter) for years, but which software did you try? Did it take a long time to do a scan or did most of the files (the ones you mentioned were working) appear pretty much instantly in the results? If it was fast, it means it found the deleted pointers to the data in the file table and recovered the files that way instead of scanning the hard disk for raw data that could be interpreted as a known filetype.

It could just be that the data got (partially) overwritten before you tried restoring it and the result is the messed up file you see.

Edit. Not sure I’ll be able to do much, but I could take a look at the file you managed to recover and see if I could come up with something. PM me a link to it if you want to.


#32

@nassi I’m PM ye. And yea, it was hours before I realised what had happened.

I did System Restore. Got back the same stupid icons I had wanted to delete. Also got back the parent folder on the desktop - not one file in it, corrupted or other. No option to restore to previous version when I right clicked either.

Also, Google Chrome decided to only run as a background process now, so I had to log in using Opera.

Now I’m not sure if to try recovery again. System Restore only gave me a bare 2 restore points and neither of them helped. I don’t know if there’s a way to find older ones. Before, you used to see a calendar and just pick the date you wanted. Dunno what’s up with Win 10.


#33

Microsoft translator detects it as Japanese and it says “We’re going to have to do this.”


#34

It’s nonsense in Japanese and contains a non-CJK symbol, looks like binary data that overwrote the old file. The repetition of 刜 is also pretty weird and seems like an artefact of structured binary data being interpreted as text.


#35

That’s a coindink and possibly right as I had tidbits of Steam Chat in the file as well. Nice find!


#36

Yes, when I tried to put the whole file in Google Translate, they figured it was some kind of binary file - but Chrome is being a bastard and not running, so I don’t remembered what they label they flagged it as…


#37

So I tried to figure out some of the things listed in Notepad++.

They are Unicode Control Codes.
"control characters are used to control the interpretation or display of text, but these characters themselves have no visual or spatial representation."
Copy pasting information would explain why all the control codes are there, but not why they are showing.

What’s more interesting is that GTranslate is picking up information that doesn’t always appear in the text like “which is the best way to do it”


#38

It does sound interesting and I was going to try to break up the “text” into Google Translate, but I’ve not slept in a good few hours - too tired to process that kind of minutiae.

It’s like a weird jigsaw without the box puzzle cover and a few random pieces thrown in. A machine coder would be more on the ball than I.


#39

OK…I have tried half the afternoon and then I had to start dinner, thought about it all through dinner, took a short walk on the friendship trail and watched a few shows with the hubby.then .tried the Bing-Japanese thingy got a few phrases out of but nothing intelligible. I am taking a break.


#40

Totally a good idea and thanks for trying so much. I’m guessing the file is super corrupted - perhaps overwritten by something in the hours that lapsed between deletion and me finding out what happened.

It sucks… it hurts bad, but perhaps it’s best if I just give up on it. It’s a pity, but hey, the backlog exists, right?

(It still sucks a lot.)