iO On Linux

I wanted to give the other Linux users a heads up about iO. Better late than never I suppose, even though almost all of the coin shop keys have been claimed.

I run Mint on all my machines. The game seems to run like it should on my desktop, but its window rapidly opens and closes repeatedly on my laptop, making it impossible to play. This glitch should come with a seizure warning, it’s pretty bad.

I reported it to the developers on the Steam forums. I’m not complaining and I don’t want a refund…it only cost me a few Chrono Coins in the first place. I just wanted to let others know that iO doesn’t quite run on ALL Linux boxes yet.


Interesting that you’re getting such varied results despite all your systems running Mint. Especially so since it’s a unity game, which in my experience tend to just work. Maybe something to do with the GPU driver on the laptop? Didn’t have problems playing it on my Arch laptop using 2nd generation intel HD graphics. I guess you could try launching it via the terminal and seeing if you manage to catch an error message. Something like “steam steam://rungameid/324070” should work (untested). You could also take a look at the Steam/game folder and see if there are logs to be found (~/.share/Steam/steamapps/common/iO and ~/.cache/{game/company name} respectively).

Linux compatibility in general is an interesting topic though, especially when one is not using Ubuntu or its derivatives, since those are usually what the developers target on the Linux side. For example Hero of the Kingdom 2 touts Linux support, but I’ve yet to get it running on any of my Arch machines. Last time I tried it I even happened upon a forum post by someone else running Arch (might’ve been a derivative like Manjaro too) with the same problem and the only reply was from the developer stating that only a certain version of Ubuntu was officially supported (as it says in the system requirements on the Steam page I guess).

1 Like

Works fine for me on Arch with the foss AMD driver. Are you using a different window manager from Mint’s default? Also would be helpful to know your GPU/driver combo.

I tested in both Cinnamon/Muffin and bspwm, neither had that particular issue. I encountered a couple of other issues; the mouse cursor stayed on the screen the whole time and kept moving back to the same spot, also the controller support did not function.

I looked at the steam reviews and one of them complained about a stutter, which may or may not be related to the issue you are experiencing. The reviewer attributed it to using a 144hz monitor, but I don’t own one so I couldn’t test it.

1 Like

I thought I would report in with my findings while I wait for a reply on the Mint forums. This wasn’t supposed to turn into another episode of “Bekk Breaks The Computer”, but it has…oh well, I needed a distraction anyway.

I looked for log files and there weren’t any. I ran iO from the terminal. Same glitch, but no errors reported. I used the NVidia X Server Settings tool to switch from the NVidia driver to the Nouveau driver. That fixed the window problem, it stayed open. I didn’t notice it at that time because I was in a hurry to get back to my classes, but the cursor does stay “stuck” to the center of the screen as chraffx says. I just checked that again a few minutes ago.

Here are some of the specs…

Laptop: MSI GP72 Leopard Pro-401
Video: NVIDIA GeForce® GTX1050TI
Recommended NVidia Driver: nvidia-384
Desktop: Cinnamon 3.4.6 (Gtk 3.18.9-1ubuntu3.3)
Distro: Linux Mint 18.2 Sonya - 64 bit

…but I’m not really worried about iO at the moment. I can play it on my desktop, if I like. It’s AMD all the way and that seems to be the key in this case. No flashing window or hanging cursor on there.

My current dilemma is that when I wanted to switch back the the NVidia driver, I couldn’t. I should have just left it alone, but most of the settings in the NVidia X Server Settings tool were also gone and I use some of those. I partcularly like the GPU temperature monitor. It helps me keep things running cool.

Long story short, I’ve spent the day removing and installing drivers and tools, changing settings and looking for answers. Everything I’ve tried has made things worse and I’m down to only being able to run in Recovery Mode.

But the good news is…we managed to partially troubleshoot iO before I let everything get away from me. Thank you! :smiley:


As someone who knows…well, nothing about Linux all I can say is it sounds super tasty!



mrw i have a tech issues when gaming on linux


You two made me laugh in the middle of a computer crisis. That’s a rare talent…many thanks! :smiley:

It’s still not fixed, but we’re getting there. It would help if all of my PC problems weren’t completely insane.


Liked for the penguin drop. Can’t say how many times I did it IRL…

That penguin and I had a love/hate relationship.