Back to Today's Deal

I need help: Just upgraded from Win 7 to Win 10 and now most of my games won't work anymore


#1

Like the title says, I have trouble launching my most beloved games since I upgraded to Windows 10 on Thursday. I uninstalled the Win 7 version of the GPU driver and installed the newest version for my card (Radeon RX 480) under Windows 10. But judging by the error messages, something related to DirectX and the driver went wrong.

Some Games that won’t work:

Battlefield 1, with the following Textbox:
DirectX function “device-> CreateTexture2D( &texDesc,
desc.subResourceCount != 0 ? reinterpret_cast<const
D3D11_SUBRESOURCE_DATA*>(desc.subResourceData) : 0,
&texture->m_texture2d)” failed with E_INVALIDARG (“An
invalid parameter was passed to the returning function.”).
GPU: “Radeon™ RX 480 Graphics”, Driver: 20.2.2 (19.50.19.19-200228a-352369C-RadeonSoftwareAdrenalin2020)

Company of Heroes 2, with the following Textbox:
Failed to find supported hardware rendering device. Verify that DirectX is properly installed and that you have the latest drivers for your system

Far Cry Primal (launches minimized and doesn’t react to clicks or anything, only option is killing it via Task Manager)

Games that DID in fact work:

Anno 1800, tried it out for the weekend and played without any issues for 7 hours straight.

Fallout 76, decided to give it a try again. It was ugly AF, but I don’t think that has anything to do with my system lol.

Before, all games worked flawlessly in 1920x1080 Fullscreen.
It seems to have nothing to do with where I launch these games from, since they’re all from different launchers (Steam, Origin and UPlay) and I tried launching them from the launcher, the desktop symbol and directly the .exe in the respective folders.
I already tried deleting configs for BF1 and CoH2, uninstalling and reinstalling the Radeon drivers a couple of times and I’m at my wit’s end right now.
I’d be so grateful if anyone has any suggestions for me on how to fix my DirectX/driver problems.
Thanks in advance for reading this and for your help!


#2

well, dumb question, but have u updated directx? and have u in fact also updated your windows 10 after having upgraded to it?


#3

Thanks for the quick answer. Yes, I ran every update for Win 10, making sure it was 100% up to date before I did anything else after upgrading my OS.


#4

could it be possible that some games install differently depending on which windows you have at that point in time? I do think I remember some games used to ask me if i wanted 32-bit version or 64-bit version with Windows 7. If i remember right windows 7 might be either, and maybe u had 32 but windows 10 uses 64 , and maybe that’s the issue here? no idea, just a thought

so maybe try just doing the verify integrity thing, if that doesnt work, look for the smallest game and reinstall to see if that fixes it, and if it does then i guess u have to reinstall all those which dont work


#5

Download a small game from steam and run it. MS updates I don’t think cover DirectX properly. Basically let steam do the first run setup (which includes DirectX) and see what happens.

If you have two drives, I would recommend pulling everything important to the second drive, grabbing the Win10 key you are using, shut down, unplug the second drive, and fresh install windows 10. As in, complete wipe. (you’ll also need a win10 installation media, which you can create on a flash drive)

If you don’t have 2 drives then fresh installing a bit less convenient.


#6

Indeed, old versions of DirectX are not kept up to date automatically.

Some Steam games are able to resolve these dependencies. You may need to install more than one because they do not all use the same runtimes. Basically, install and run a handful of your favorite Steam games. The “initial setup” will likely resolve your DX issues.

Failing that, you can download old runtimes from the Microsoft site directly. I have found installing directx_Jun2010_redist, DirectXwebsetup, and NetFx20SP1_x64 is usually enough to resolve any runtime issues I have after a refresh.


#7

You’re going to want to reset your PC. The best way to do this is by installing Windows 10 to a flash drive with a media creation tool.

Hopefully I’ll be able to make a second post soon with more details. Basically Windows upgrades can be janky and Windows can totally be fixed with a flash drive. Just make sure to back up documents and such beforehand, just in case.


#8

It isn’t really advised to upgrade from Win7 directly to Windows 10, and if you do, it is highly advised that you reset immediately. Save important files (appadata, games etc) to another drive and rest.

However, it sounds just like a GPU issue, so it is worth checking to see if clearing drivers entirely from your PC will work. Download DDU (Display Driver Uninstaller) and reboot into Safe Mode. Once inside Safe Mode, run DDU and use all of the recommended options, making sure AMD is selected to the right. Once it is run, it will reboot you into Safe Mode if you did so through msconfig, if not it should bring you back into normal Windows 10. If not, reopen msconfig and uncheck safe mode and reboot.

Now, download the new driver again (unless you didn’t delete it) and reinstall. This ensures there are no corrupted drivers or such left behind, and is advised every update, or at least every 3 updates.

Hopefully that works for you and you don’t need to reinstall Windows.


#9

A RE: to my own post…

Here’s the link to the official Media Creation Tool.
https://www.microsoft.com/en-us/software-download/windows10

You can use this to put Windows 10 on a flash drive, provided it has enough free space.

Boot onto that computer from the POST, and you’ll be able to repair your Windows installation or reset it. Again, back up your important files just in case.

Windows upgrades are finnicky and lots of things can go wrong so the sooner you do this, the better.


#10

I am experiencing the same thing. What I did was download direct x 8, 9, and 10 and make sure 11 is up to date. I finally got all my popcap games to work. You may have to run theme in compatibility or as administrator. Plus a bunch of people have “fixes” out there. I had to use them a lot. Google/DuckDuckGo is your friend and search through steam itself. Just be careful out there.


#11

Hello friends, and thanks a lot for all the replies!
It’s been a busy time since I opened this thread, and now I can finally give you an update:
I tried everything that didn’t involve completely wiping the HDD and nothing worked, and since I’ve been using the dive for ages now and it always took a long-ass time to start, I went and bought an SSD with a similar, slightly bigger size (256GB), and installed Win10 from scratch on there. And after installing and running steam games of varying age, I know have all the DirectX, .NET and Visual C++ Frameworks and all my games and programs work fine again. Plus, seeing my baby start in 20 seconds is a real treat.
So, thanks for everything, guys!