Back to Today's Deal

I can't login to Chrono through Chrome [Solved! Much Thanks! <3]


#1

As the title says, I can’t log into Chrono on my Chrome.

When I opened up my Chrome this morning, I found I was logged out of Chrono. Then when I go to log in the Captcha keeps telling me to try again. I cleared my cookies and even tried changing my password since that was the whole point of me logging in now anyway.

I can log in just fine on my Firefox so I don’t know why it won’t work on Chrome when it has been just fine for years before.


#2

Do you know if chrome recently updated? Which version are you running and have you tried in ‘safe mode’ with all plugins and such disabled?

Any other information you can think of that might be help @dusty, @frst or @lonin narrow down the possible issues?


#3

Turn off your extensions to see if one of them is blocking you maybe?


#4

Hi! Firefox and Chrome’s captchas sometimes behave differently for some reason (I’ve been there). This is unlikely to be a Chrono-exclusive problem. So:

  1. Are you using a VPN? If so, try changing locations.
  2. Are you having the same issue on other websites?
  3. What is the exact error you’re getting?

This video may help, it tackles a slightly different issue but the process may help solve yours too:


#5

Sorry to hear that! If you’re still having issues through us an email at help@chrono.gg.


#6

Thanks for all the replies, y’all!

To go down the list:

  1. I have all the same extensions on my Chrome that I do on my Firefox, but I tried it in Safe Mode anyway. Still no dice.
  2. I’m not using a VPN.
  3. I haven’t tried the Captcha on another site because I don’t know of any other site I’m on that uses them.
  4. The error I’m getting just keeps telling me to “Try again.” It’s like I’m failing the Captcha even though I know I’m not. There’s no error code or anything like that.
  5. My Chrome is up to date. I don’t know if the update is recent though because it doesn’t show me the last time it automatically updated.

TL;DR Version: The only recommendation I haven’t been able to test is Captcha on another website as I don’t know another site I’m on that uses it.


#7

https://patrickhlauke.github.io/recaptcha/

Try this and let us know if it works! :blush:


#8

Thanks for that! I tried the Captcha link on both the Firefox and the Chrome and it only worked on the Firefox, so seems like just a Chrome issue.

I did the flush from the video for a second time and, after the restart, I was finally able to get in on the Chrome . I tested it by signing in and out to see if it’s a fluke, but I am able to get in after multiple failures each time. I’ll take the failures since at least it doesn’t fail me on all of them and give me the finger like before.

Thank you so much for the help! I just got paid today, so I was very upset that Chrono didn’t want my money. XD


#9

I’m so glad everything worked out! Happy spending. :blush: :money_with_wings: