[FIXED] Subscribe Newsletter in Settings not working

Hey guys,

I cant subscribe to the newsletter in the settings. Please fix.


That’s not good! Would you mind describing what’s happening?

Hey Christian, super sorry about that!

Would you mind logging out, logging back in, and trying to subscribe one more time? :blush:

Logging out and back in did the trick! thanks for your help. :slight_smile:


Hey guys,

I ran into the same issue, I can’t subscribe to your newsletter. When I click the button it says processing for about about a second but then nothing happens.

I tried logging out and in again, incognito window, different browsers but nothing changed.

Can you help me fix this?

Thanks a lot in advance!


We’re looking into it!

I’m getting this issue myself now after just having created an account. I even tried a different browser and stil it had no effect.

We found the bug, we’re working on it!

Hey @Dave247, we just pushed a fix for this. Would you mind trying again?

@lonin First I want to mention that I found I was able to subscribe to the newsletter a few days ago by simply typing my email in while logged out.

Antway just I tried it now and was able to successfully unsubscribe and then re-subscribe both while logged in, which was what I wasn’t able to do before.


Awesome, glad to hear. Sorry for the hassle!

I have the same problem, can you fix @lonin?

Looking into it!

1 Like

Any progress?

After some testing we’re unable to replicate any issues. Would you mind detailing the problem you’re having?

Stays like this forever.

Looking into it!

1 Like

This is the error I get: