I as anyone else having difficulty loading the main page under Firefox? All I’m getting is a blank purple background.

1 Like

not me, but i rolled back from the 55 update to 54, because it messed up video streams for me
tried the usual? clear cache and cookies?, tried without addons/safe mode to see if any one of them new legacy is the culprit?
is the site loading properly, i.e. is it done or does it keep “spinning” in the tab bar

I have 55.0.3 installed and I encounter no problems loading up the main page or any other page.

Mine shows up, but I just registered and can’t buy the game because they’re not sending the verification email. Don’t know if it’s related or not.

1 Like

no severe problems, I’m just getting logged out once in a while but that’s it. I’m using 55.0.3

1 Like

Hey @av2zeal, what version of FF are you using and what OS? We aren’t able to reproduce this on our end but we’d certainly like to try and fix the issue for you if we can.

@sthowe1games Send us an email at with the email account you’re trying to register with and we’ll check in on the status of the email. In the meantime, you can still purchase the game just by providing your email at the time of purchase without needing a registered account. And as long as you register your account with the same email we’ll keep track of those past orders for you :slight_smile:


I am using FF 55.0.3 (32-bit) with Win7 and having no problems at all.

I’m using FF 55.0.3 (64-bit) with Win7. I also tried on 32-bit Win7 and 55.0.2 on Android. All produced a blank purple page. Tried again today and everything works as normal, so I don’t know what changed, but I no longer have this problem. Thanks all!

  1. Same with me. FF shows blank purple screen with stuff. Opening source it “says” i need to enable javascript bs?
  2. I use chrome… log in. Then I refresh my firefox and now firefox version loads…
  3. weird…?
1 Like

Although I dislike posting into this topic with a non-descriptive title, I guess I have the same issue.

Blank purple page.
CTRL+F5 to reload assets did not help.
Disabling privacy badger and uBlock origin did not help.
Worked fine before for a long time.

Console logs:

TypeError: ERROR.captureStackTrace is not a function

for (which is the async script tag for google analytics).
No other errors logged.

Works fine on Android Firefox btw.

Site seems to have been fixed. Shows up fine now.